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The spreadsheet is the fundamental building block of computer-assisted journalism.  Every
reporter in every newsroom ought to have access to one, and know how to use it.  Why?
Because it's an inexpensive tool that will run on any computer and make your life easier
almost any time you're presented with numerical information.  Put it in your toolbox and
you will almost certainly be a better reporter.

A government budget

You are the municipal reporter covering the city of Lotsograft, Fla.  One day in June, the
city manager presents his proposed 1992-93 budget to the City Council.  He makes a few
remarks about how tough the times are, and how he has to propose a tax increase.  You
return to the office with a bound copy of the budget document. You have an interview
with the city manager scheduled in an hour, so you start looking over the budget to figure
out what questions to ask.  Here's what you find near the front:

Description 1991-92 1992-93
EXPENDITURES
Police $18,965,491 $19,533,115
Fire $  8,899,063 $10,499,501
Garbage service $  7,063,201 $  7,801,356
City Council $  1,212,007 $  1,921,055
City manager's office $     818,015 $  1,573,216
City attorney $  3,621,748 $  4,950,713
Total expenditures $43,690,312 $48,125,201
REVENUES
Property taxes $24,316,255 $27,996,305
Utility taxes $  5,669,305 $  5,901,165
User fees $  1,005,699 $  1,733,922
Water & sewer $10,559,300 $11,215,883
Total revenues $43,690,312 $48,125,201
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How are you going to start making sense of this budget?  Probably the best thing to do is
figure out which budget categories (expenditures and revenues) are proposed to increase
the most.  Follow along as we use the spreadsheet to uncover the mysteries of  the
Lotsograft budget.

Typing numbers into the spreadsheet

For appearance's sake, leave the first row blank.  With the mouse, move to cell A2 and
type the word Description.  (After filling out a cell, you can press <Enter> or simply use
the mouse to move to the next cell you wish to fill out.)

Then, in cell B2, type 1991-92.

Now another problem: The word "Description" is partially obscured by the contents of cell
B2.  You'll need to widen the first column.  To widen it, use the mouse to move the mouse
to the vertical line separating column A from column B.  You'll see a symbol that looks
something like this: <-|->.  Now click and drag the vertical line to the right (hold down the
left mouse button and move the mouse) until the column width is adequate -- you may
want to drag it far enough that there's room in the column for the "City Manager's Office"
line from the budget.

Now enter the budget categories in column A, the '91-'92 budget figures in column B and
the '92-'93 budget figures in column C.

Midway through your data entry process, your spreadsheet should look something like
this:
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When you enter the numbers, do NOT include dollar signs, commas, percent signs, etc.
You should  format the cells  after  you have typed in all the budget numbers.

To format the numbers as dollars, first "select" all the cells that should be in currency
format.  Here's how: move the mouse to one corner of the block of cells, click with your
left mouse button and hold down the button as you drag the mouse to the far corner of the
block.  All the cells will turn dark, with light type (instead of the reverse).  Now, move the
mouse to the big $ button in the upper right of your Toolbar.  (You should see "Currency
Style" pop up.)  Click on the button.

Oops!  Something has happened to your cells.  Instead of numbers, you now see a bunch
of  ######## signs.  That's because your columns aren't wide enough.  Widen the columns
(click and drag on the | separating the column headers).

Since there's no reason to show cents, let's remove the zeroes to the right of the decimal
point.  Move the mouse to the "Decrease Decimal" button in the Toolbar.  (It's at the far
end of the bank of buttons that includes the $ or "Currency Style" button we used earlier.)
Click on the button twice to remove the two decimal places.

Saving your spreadsheet

All commands to save or call up a spreadsheet are contained within the File menu. You
can Save (write to disk while leaving the spreadsheet on your screen); Close (in which
case you'll be prompted whether you want to save your changes); or Save As.

You want to save your property tax spreadsheet and give it a name that you'll remember.
Here's how:

Go to the Edit menu and choose Save As.(note that the single letter to type is A); to
revise the filename, just type in the proper name -- say, PROP plus your initials.  Then
click on the OK button.

Calculating expenditure increases

It's time to examine the budget.  The first logical question: How much did total
expenditures rise? Let's start by looking at dollars only.  In cell D10, type =C10-B10.
You have to enter the = sign because otherwise the spreadsheet thinks you're typing a
label.  You see all those ####### signs.
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Widen the column.  Now you're getting somewhere: overall, city expenditures have risen
about $4.4 million.

Let's examine the categories of expenditures.  And here's the beauty of the spreadsheet.
Instead of typing =C??-B?? in every cell, you can COPY the formula.  The spreadsheet is
smart enough to understand which cells you want to subtract.

To copy a formula, you will once again click and drag.  First click on cell D10.  Now, look
at the small square in the lower right corner of the cell border.  This is known as the "Fill
Handle."  Move the mouse to that corner, and the pointer changes to a cross.  Now, click
and drag the fill handle upward to cell D4 (the first row of expenditures).  Release the
mouse button.

As you can see, there are now numbers in cells D4 to D9.  If you move your cursor into
the cells, you can see how the formulas were copied.  In cell D7, for example, the formula
shows =C7-B7.  The answer: $709,048.

This is a good time to point out that the power
of the spreadsheet can cause real problems if
you make a mistake in your thinking. For
example, if you compute a percentage
incorrectly, you can very easy turn one error
into dozens of errors by copying that formula
over and over and over again.  So check and
double check your work.
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Excel is also smart enough to realize that all these cells should be in currency format with
zero digits to the right of the decimal.  Type the word Change in cell D2 to indicate what
the column represents.

Again, some things are looking interesting.  On the screen, note the categories with the
biggest dollar growth in expenditures (Fire and City attorney).  And note the formula in
cell D7 (=C7-B7).

Calculating percentage change

Now let's look at the same information as a percentage change instead of a dollar change.
Type Pct. change in cell E2. Then, in cell E10, type =D10/B10.

Remember the formula for percentage change between X and Y:
(Y-X) divided by X.

Because column D already is the result of subtracting column C minus column B,
all you need to do is divide by column B to get your percentage change.

You'll see that the number registers as a decimal rather than as a percentage.  Let's format
it properly.  If it's not already selected, select cell E10.  Move the pointer to the big %
button in the Toolbar and click on it.  Now move to the "Increase Decimal" button and
click once so you get one digit to the right of the decimal.  In cell E10, you see that
expenditures overall have risen 10.2%.
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Copying formulas

Now, copy the contents of cell E10 to the range E4 to E9.  Voila!  Some interesting stuff!

While police expenditures are going up only 3 percent, the Fire Department is getting 18
percent more, the City Council 58.5% more and the city manager's office 92 percent more.
Aren't these some things to ask that city manager about?

Having made sense out of the expenditures, let's turn our attention to the revenues.
Again, here's the beauty of the spreadsheet.  Since we want to do the same thing with the
revenues as we did with the expenditures, all we have to do is copy the formulas in cells
D10 and E10 into columns D and E of the revenue rows.  Select D10 and E10 by clicking
and dragging with your mouse.  Then drag the fill handle downward to the last revenue
row, and release the mouse button.

Again, some interesting stuff.  Property tax revenue is up 15 percent, while "User fees" are
up 72 percent.  What does that mean?
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A slight problem:  Since you copied the formula into the blank row between expenditures
and revenues, Excel has put formulas in places that don't really make sense.  In cells E11
and E12, you see #DIV/0! That means you're trying to divide by zero.  Let's erase, or
clear, the contents of cells D11, E11, D12 and E12.  Select the cells, then press the Delete
key (usually to the right of your typewriter keyboard).

Sorting your data

Let's now demonstrate another spreadsheet tool: the sort function.  This isn't real valuable
on a small spreadsheet like the one you have in front of you, but it is very helpful if you're
working with a large set of numbers.  For an exercise, we'll sort the expenditure categories
by the percentage change from one year to the next.

To sort, first select the block of cells you want.  In this case, you need all of the
expenditure rows except the Total row -- which we want to leave at the bottom -- and all
columns. Be sure to include the text cells in the first column.

It is VERY important that you select the sort block correctly.  For example, if
there were another column of numbers in column F, and you failed to include it in
your block, after you sort, those numbers would no longer be aligned properly
with the numbers in the other columns.

Move your mouse to the Data menu in the Menu bar and select Sort.  The Sort dialog
box will appear.  You want to sort by Column E (the percent change).  To change the sort
column, you can type in "Column E."  But the easier way is to click on the small down
arrow and move your pointer down to Column E.

Specify that you want the sort in Descending order by clicking on the appropriate button.
Click on the OK button to perform the sort.

Now, do the same kind of sort on the revenue category.
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Inserting columns

Let's try to answer another question: What proportion of Lotsograft's revenue is coming
from property taxes (and other sources)?

First, let's insert a column between columns C and D.  Move the  pointer anywhere in
column D.  Then move to the Insert menu in the Menu bar, and choose Columns.  Since
you only want to insert a single column, that will be enough.  (If you wanted to insert
several columns, you would have selected the number of columns to insert before you
went to the menu.)

Note that even though a column has been added, the spreadsheet has adjusted the
formulas in the columns that moved.

Go to cell D2 and type Pct. 93total.  Then format column D as percentages by selecting
the entire column and clicking on the % button.

Calculating percent of total

In Cell D13, type =C13/C17.

Then copy that formula to the rest of the revenue rows.  Oops!  It shows an error -- three
of them, in fact.  Why? Look at cell D14.

The spreadsheet is trying to divide by the contents of C18, which is a blank cell.  If you're
dividing each of a range of cells by the contents of one unique cell, copying won't work
properly. But, there is a solution:
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Go back to D13.  Type =C13/$C$17.

What you've done is tell the computer that wherever you copy this formula, it should
divide by the contents of cell C17.  Now copy the formula to the rest of the revenue rows.
Property taxes make up 58 percent of total revenue.

ON YOUR OWN: Do the same calculations for the revenues in 1991-92.  And
then do them for the expenditure side of the budget.
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Using =SUM

There's one more concept in formula-writing for spreadsheets: the worksheet functions.
These are shortcuts, enabling you to type in a few keystrokes something that would
otherwise take a lot of typing. The most common one you will use is  =SUM.  This
function allows you to add the contents of a range of cells.  You type:

=SUM(B1:B7)
The result is the same as if you typed =B1+B2+B3+B4+B5+B6+B7.

Just out of curiosity, let's see if the itemized revenue figures for 1992-93 add up to the
total, or whether there's some secret source of revenue in the budget.  Move your cursor
to C19. Type =SUM(C13:C16).  (In fact, you don't need to capitalize any of these
letters.)

Hmmm.... Money appears to be missing.   And by copying this formula to cell B19, you
can compare the amount of missing money to the amount for the previous budget year.

Hiding columns and freezing panes

Although you can only see a screenful of information at any one time -- generally 20 rows
and five to seven columns -- your spreadsheet can be as huge as you're ever likely to need.
But a huge spreadsheet can be hard to use.  There are two tools that make it easier: hiding
columns and freezing panes.

Let's say that for the time being, you don't care about column D.  To hide it, first put your
pointer someplace in that column.  Go to the Format menu, then select Column.  One of
your choices is Hide.

You haven't changed the original spreadsheet. But column D no longer appears on your
screen.  Now bring it back, by returning the the Format | Column menu and choosing
Unhide.

The other tool to make a large spreadsheet readable is called freezing panes.  Look on
your screen.  You can't see column H.  But if you move your pointer to column H, you
can no longer see the budget categories in column A.

To make them visible, move your pointer to column B, select the column as far down as
your data goes.  (HINT:  You can do the same thing by simply clicking on the B column
header.)  Then go to the Window menu and choose Freeze Panes. Now scroll to the
right; note that the first column remains in place and the other columns seem to disappear
behind it. Now undo what you did.  Go to the Window menu and choose Unfreeze
Panes.

For a long spreadsheet, you can freeze the row of titles across the top as well.  To do so,
move your pointer to the row BELOW the one you want to lock and select the row.
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Again, go to the Window menu and choose Freeze Panes.  Once you've done that, undo
it.

Now go to the Edit menu and choose Close.  You are ready for the next lesson.


